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ABSTRACT
This application report describes the performance of the digital signal processing (DSP) CPU extension of
the MSP432™ microcontroller (MCU) leveraging the standard CMSIS DSP library in FFT operations. This
is a software implementation that demonstrates several high-performance analog and digital integrations
through various operations including CPU and DSP (visualization, vector processing), DMA, ADC, and
high-speed SPI (color LCD control) with a high-degree of parallel operations.

Related software can be download from www.ti.com/lit/zip/slaa707.
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1 Introduction
Features of this application include:
• Real-time FFT using accelerated hardware
• Graphical visualization on a color LCD with high-speed serial communication

2 System Description
The Fast Fourier Transform (FFT) algorithm converts a time-domain signal to frequency-domain and vice
versa where FFT is manually used in many applications in signal processing. The ARM® Cortex®-M4F
DSP extension, in conjunction with the CMSIS DSP Library, is designed to perform vector-based
operations such as FFT, FIR, matrix multiplications, and more in an efficient manner. The software
example in this application report demonstrates the clock cycles required to execute a real-time 512-point
FFT using CMSIS DSP Library. This application report also demonstrates the high-performance features
of the MSP432 MCU including the 48-MHz Cortex-M4F CPU and the high-speed SPI communication
through graphical data manipulation and FFT data visualization.

Figure 1 shows a high-level overview of the system function.

Figure 1. High-Level Overview

To get started with this application, the user is required to use the MSP-EXP432P401R LaunchPad™
development kit, and the BOOSTXL-EDUMKII BoosterPack™ plug-in module. See Section 5.2 for help
getting started with the Educational BoosterPack MKII with the EXP-MSP432P401R LaunchPad
development kit.

2.1 MSP432P401R
The MSP432P401R MCU is a 48-MHz 32-bit Cortex-M4F ultra-low-power MCU with 256KB of flash and
64KB of SRAM. This MCU integrates various digital and analog peripherals, many of which are used by
this application, including the 1-Msps 14-bit ADC, the 48-MHz performance, the DSP extension of the
Cortex-M4F CPU, the high-performance DMA, and the high-speed SPI serial communication.

Overall, the MSP432P401x is an ideal combination of the TI MSP430™ low-power DNA, advance mixed-
signal features, and the processing capabilities of the 32-bit Cortex-M4 RISC engine. The devices ship
with bundled driver libraries and are compatible with standardized components of the ARM ecosystem.

To find out more on MSP432P401R, see http://www.ti.com/product/msp432p401r.

2.2 Cortex-M4F With DSP Extension
The MSP432 Cortex-M4F processor features a single-cycle multiply-accumulate (MAC) unit, optimized
single instruction multiple data (SIMD) instructions, saturating arithmetic instructions, and a single-
precision floating-point unit (FPU). These digital signal control features build on the innovative technology
that characterizes the Cortex-M family of processors. These features include a 32-bit core capable of 1.25
DMIPS/MHz for high performance, Thumb®-2 instructions for optimum code density and a Nested Vector
Interrupt Controller (NVIC) for outstanding interrupt handling.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLAA707
http://www.keil.com/cmsis/dsp
http://www.ti.com/product/msp432p401r
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The CMSIS DSP library provides a suite of common signal processing functions for use on devices based
on the Cortex-M processor. The implementation on Cortex-M4F fully leverages the integrated DSP
instructions to provide robust vector math operations including:
• Basic math functions
• Fast math functions
• Complex math functions
• Filters
• Matrix functions
• Transforms
• Motor control functions
• Statistical functions
• Support functions
• Interpolation functions

For more information, see the CMSIS DSP Software Library at
http://www.keil.com/pack/doc/CMSIS/DSP/html/index.html.

2.3 14-Bit ADC
The MSP432P401R microcontroller has an on-chip 1-Msps 14-bit SAR ADC that is used to continuously
sample the microphone output at 8 kHz. The microphone has a front-end operational amplifier. The output
of the op amp is connected to ADC channel 10 (P4.3). To ensure a deterministic sampling rate, the ADC
is automatically triggered by Timer_A0 channel CCR1.

2.4 µDMA
When the ADC sample is completed, the data is automatically moved to one of the two SRAM buffers
using DMA channel 7. The µDMA module on the MSP432 MCUs acts as a separate master on the bus
and does not interfere or stall the CPU access. The µDMA modules as a master enables parallel
operations with the CPU executing code while the ADC sampling and DMA transfers occur.

3 Block Diagram
Figure 2 shows the block diagram of the application.

Figure 2. Block Diagram

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLAA707
http://www.keil.com/pack/doc/CMSIS/DSP/html/index.html
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4 System Design
This application uses the DSP extension of the Cortex-M4F CPU and the CMSIS-DSP library to perform
real-time FFT with audio sampled using the onboard 14-bit ADC from microphone on the Educational
BoosterPack MK II.

To ensure a real-time performance with no sample loss during processing, this application implements
dual-buffered memory to store the ADC samples. When a buffer is full, the application starts processing
the buffer while the application continues to sample the ADC in the background into the secondary buffer.
A ping-pong scheme is set up for the µDMA, where the primary and alternative channel controls are
configured to fill their respective 512-sample-deep data buffer. When the primary data buffer is filled, the
DMA switches to the alternative data buffer while FFT processing on the primary data buffer begins in
parallel.

Figure 3 shows the application flow chart.

Figure 3. Application Flow Chart

4.1 Real-Time 512-Point Real FFT
The MSP432 MCU combined with the CMSIS-DSP Library supports up to 8192-point real and complex
FFTs. This application demonstrates the performance of a 512-point real FFT. This application collects up
to 512 ADC samples from the onboard microphone before starting the FFT routine. To ensure real-time
FFT performance, this application implements a dual-buffered array where one buffer is always being
filled, while the other is processed. The audio is sampled at a rate of 8 kHz using onboard intelligent
peripherals such as the timer that automatically triggers the ADC to sample. The advanced µDMA moves
the data to memory completely independent of CPU operations. A Hann window function is applied on the
sampled data to further reduce the noise from the microphone input. The CMSIS-DSP API arm_rfft_q15()
then performs the real FFT where the FFT output contains real values. The magnitude is then calculated
and contains 256-point positive and negative frequencies. Because the display is only 128 pixels wide,
each two adjacent frequency bins are combined, averaged, and displayed as one bar on the output graph.

Figure 4 shows the timing diagram.

Figure 4. Timing Diagram

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLAA707
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5 Getting Started Hardware
Figure 5 shows that this application uses the MSP-EXP432P401R LaunchPad development kit with the
BOOSTXL-EDUMKII Educational BoosterPack plug-in module.

Figure 5. Stacked LaunchPad Kit and BoosterPack Module

To power the LaunchPad development kit, connect the Micro-USB connector.

5.1 MSP-EXP432P401R LaunchPad Development Kit
The MSP-EXP432P401R LaunchPad development kit is based on the MSP432P401R microcontroller
featuring a 48-MHz Cortex-M4F CPU and a wide variety of MSP analog and digital peripherals including
the 14-bit ADC, high-speed communication, and enhanced security features. The MSP-EXP432P401R
LaunchPad development kit integrates an onboard XDS110 debugger capable of programming and
debugging the MSP432P401R MCU through JTAG, SWD, and BSL. The MSP-EXP432P401R LaunchPad
development kit includes a standardized 40-pin header to enable interfacing with a wide variety of
BoosterPack plug-in modules.

To learn more about this LaunchPad development kit, see http://www.ti.com/tool/msp-exp432p401r.

5.2 BOOSTXL-EDUMKII Educational BoosterPack MK II
The BOOSTXL-EDUMKII Educational BoosterPack MK II offers a high level of integration for developers
to quickly prototype complete solutions. Various analog and digital inputs and outputs are at your disposal
including an analog joystick, environmental and motion sensors, RGB LED, microphone, buzzer, color
LCD display, and more.

Figure 6 shows the modifications that this application requires to the BOOSTXL-AUDIO BoosterPack plug-
in module.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLAA707
http://www.ti.com/tool/msp-exp432p401r
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Figure 6. BOOSTXL-AUDIO BoosterPack Required Modification

For more information about the Educational BoosterPack MK II, see http://www.ti.com/tool/boostxl-
edumkii.

6 Getting Started Firmware
To get started, download the zip package from www.ti.com/lit/zip/slaa707. Alternatively, the same software
can be found in the comprehensive MSPWare software package, which is available directly in the Code
Composer Studio™ IDE, from the TI Cloud Resource Explorer, or downloadable as stand-alone package.

6.1 Code Composer Studio™ (CCS) IDE
To get started with CCS:
1. Launch CCS.
2. Navigate to Project → Import CCS Projects.
3. Click Browse.
4. Navigate to the src/CCS folder.
5. Click Finish.

6. Click the debug button to download and debug the project.

If MSPWare is installed and present in the CCS TI Resource Explorer view, steps 2 through 5 may be
replaced by navigating to the resource through MSPWare → Development Tools → MSP-EXP432P401R
→ BoosterPack Examples → BOOSTXL-EDUMKII MicrophoneFFT (see Figure 7) and importing the
project directly from this location.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLAA707
http://www.ti.com/tool/boostxl-edumkii
http://www.ti.com/tool/boostxl-edumkii
http://www.ti.com/lit/zip/slaa707
http://www.ti.com/tool/ccstudio
http://www.ti.com/tool/ccstudio
http://dev.ti.com/tirex/#/?link=MSPWare%2FDevelopment%20Tools%2FMSP-EXP432P401R%2FDemos%2FBoosterPack%20Demos%2FBOOSTXL-EDUMKII%20MicrophoneFFT
http://www.ti.com/tool/mspware
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Figure 7. Importing Project From MSPWare in TI Resource Explorer

6.2 IAR Embedded Workbench® (IAR) IDE
To get started with IAR:
1. Navigate to the /src/IAR folder.
2. Double-click on BOOSTXL-EDUMKII_MicrophoneFFT_MSP432P401R.eww to open the IAR

workspace project.
3. Click Project → Make to build the project.
4. Make sure that the Micro-USB is plugged in first to download and debug the application.
5. Click Project → Download and Debug.

7 Application Execution Performance
The signal-processing performance includes the clock cycles required to execute each FFT routine. The
number of cycles required to perform a 512-point real FFT is approximately 25392 cycles, and
approximately 530 µs at 48 MHz (IAR).

The system was designed to minimize the real-time impact due to multiple concurrent resources by
leveraging CPU and DMA operations in parallel. DMA and CPU requests and activities may occur
concurrently with minimal stalling or wait-states incurred.

The number of cycles required to perform a 512-point complex FFT is approximately 30489 cycles, and
takes approximately 635.2 µs at 48 MHz with flash configured with one read wait state (using CCS). With
further optimization and benchmarked at zero flash wait states, the 512-point real FFT function alone only
takes 25392 cycles (IAR, maximum nondebug optimization settings). Figure 8 shows detailed cycle
duration for the entire application. Major operations include: Hann window function on sampled data, FFT
calculation, magnitude calculation, maximum peak identification, graph creation, and color LCD screen
update.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLAA707
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Figure 8. FFT and LCD Operation Per Update Execution Timeline

Table 1 lists the main application operations and their durations.

Table 1. Application Operations and Duration (48 MHz With One Wait State)

FUNCTION DURATION
(cycles)

DURATION
(ms)

Hann window initialization 323952 6.749
Hann window function 10253 0.2136
FFT initialization and processing 30490 0.6352
Magnitude calculation 23515 0.4899
Maximum peak identification 3378 0.07038
Redraw graph and update LCD 1209120 25.19

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLAA707
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When the current is measured, the educational BoosterPack module is removed from the LaunchPad kit,
because the backlight from the LCD on the BoosterPack module significantly contributes to the current on
the system and dominates the system current. Figure 9 shows the current periodic interval of the system
measuring the ADC while DMA moves the data and calculates the FFT.

Figure 9. FFT Application Current Profile

8 Software Files
Download the software files from www.ti.com/lit/zip/slaa707.

9 References
1. MSPWare Software
2. CMSIS DSP Software Library
3. MSP432P401R Mixed-Signal Microcontrollers
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